| Home  Blogs Help Search Login Register  
« previous next »
Pages: [1] Print
Author Topic: JE 2.2 Temperature gauge not working  (Read 934 times)
pduke
Newbie
*
Posts: 16


« on: June 27, 2019, 07:29:13 pm »

Hi ! it has been a while...  Cry  me and the band we have parked our beloved Espace since 2016.... Unfortunately.
Today i moved a charged battery and took it for a spin down the block. I noticed that the temperature gauge on my dash is not working (the light on the upper left corner of the same gauge lights red before ignition though....). Given the older problems i had with temperatures i got frightened and parked it asap.
Could this be any fuse or something easy to fix or i need to replace all the thermostat housing?
cheers all!
Logged
Anders Dinsen
Administrator
YaBB God
*****
Posts: 2971



WWW
« Reply #1 on: June 29, 2019, 01:26:14 pm »

Could this be any fuse or something easy to fix or i need to replace all the thermostat housing?
cheers all!

It's not a fuse, but more likely the sensor. It shouldn't be too difficult to fix, but check a few things first:

- Is there the correct amount of coolant on the car?
- Was there signs of overheating when you parked the car, i.e. was the engine more hot than normal (I appreciate that can be hard to see given the very hot weather)
- Even if the level of coolant is correct, are there any signs of it leaking? Leaks should always be taken seriously and repaired as soon as possible, though they can be hard to find sometimes
- How do you see that the gauge is not working?
Logged

'82 Murena 2.2 prep 142
'01 Grand Espace 24v
'08 Smart Fortwo 0,8 cdi
Pages: [1] Print 
« previous next »
Jump to: