| Home  Blogs Help Search Login Register  
« previous next »
Pages: [1] Print
Author Topic: New pump  (Read 1328 times)
Anders Dinsen
Administrator
YaBB God
*****
Posts: 2823



WWW
« on: March 11, 2009, 07:35:16 pm »

I had another look on the SU pump that Krede had so kindly donated to me, and decided that I didn't want to give it the go anyway: It's a pressure pump so it may have problems lifting the fuel the 50 cm or so from the bottom of the tank, and it's quite old and needs some parts to be reliable.

So I called my parts supplier at www.fastroadcars.co.uk and had a chat with him, and he suggested hat the best pump for my use would be a Hüco suction pump. The Facet pumps are out of the question, since they can't lift the fuel more than about 12 inches.

The Hüco is very similar to the Biltema pump, except the quality is obviously better. This is clearly noticed when comparing them. In other words: The Biltema pump is a low quality, cheap copy of the Hüco pump.

I also found out what the exact problem was with the Biltema pump: Inside these pumps there's a solenoid pulling a shaft. The shaft is connected to the spring loaded membrane. The spring is calibrated against the size of the membrane to achieve a certain pressure on the outlet of the pump. When the membrane "bottoms out", an electronic switch turns on the solenoid and the shaft is pulled out again to start a new pump stroke. The problem was that there was friction in the shaft's movement inside the coil. This didn't mean anything when the pump was pumping quickly into an empty float chamber, but when the pressure was decreasing slowly, the shaft would stick inside the coil, and the pump would stop moving. WD40 solved the problem - for a while at least, but this really boils down to poor quality.

« Last Edit: March 12, 2009, 11:34:58 am by Anders Dinsen » Logged

'82 Murena 2.2 prep 142
'01 Grand Espace 24v
'08 Smart Fortwo 0,8 cdi
Pages: [1] Print 
« previous next »
Jump to: