| Home  Blogs Help Search Login Register  
« previous next »
Pages: [1] Print
Author Topic: air blower fan not working  (Read 2896 times)
bernieallan
Newbie
*
Posts: 6


« on: August 01, 2009, 03:52:17 pm »

hi all,

just when i needed the internal blowers to work they have cut out, any ideas anyone?

the air con switch works and all the venting buttons work but the slide control for the fan is not working.
i have checked the obvious fuses but all seems ok there. i have removed the control switch and checkedthe wires are ok and all seems fine. it looks like it may be the circuit board failed on the back of the switch console/

has anyone else had this problem?

look forward to some help guys/and gals

bernie
Logged
Elmo the Espace
Jr. Member
**
Posts: 46


« Reply #1 on: August 02, 2009, 05:30:40 pm »

Hi Bernie.
will you heater motor work on full spead if so then the problem may lie in the motor spead control resistor it has a thermo fuse which do blow cutting the supply to the resistor. I have replaced a few over the years.
Which model and age of Espace do you have as the controls have changed over the years,
Hope this helps
Chris
Logged

1965 Land rover 2a SWB
1966 Land Rover 2a SWB
2 x 1994 2.0i Espace's
Transit 140 bhp limited SWB 2009
bernieallan
Newbie
*
Posts: 6


« Reply #2 on: August 03, 2009, 10:27:26 pm »

Hi Elmo thanks for the reply.

The heater motor and blowers are not working although the vent directional buttons all work ok.

the model is 2000 2.2 tdi where is the fuse you have mentioned would it apply to this model?

regards

bernie
Logged
bernieallan
Newbie
*
Posts: 6


« Reply #3 on: August 06, 2009, 08:52:47 pm »

Hello Chris,

There is no life in the slide switch at all it is dead, the air con button works and the fan directional buttons are lit up and work its just the blower fans have cut out completely and do not respond to the highest setting or any other setting mate..

Thanks for help and apologies for wrong name..Elmo...

Bernie
Logged
fixmycar
Newbie
*
Posts: 1


« Reply #4 on: October 01, 2009, 11:13:39 am »

hi it is the resistor pack that has blown  it is located in the fan assembly under the dash board
to get to it
1. remove the speaker covers on the dash board and undo the screws to remove the top part of the dash the are 3 push to fix clips holding this to the display
2. there is a cover under this with 8 screws remove this and you will see the fan assembly.
the resister pack is on the left where the wires connect

i have a listing on renaultforums with pics
Logged
Pages: [1] Print 
« previous next »
Jump to: